Static Routing dengan Multilayer Switch Cisco



Multilayer Switch merupakan switch yang memiliki kemampuan seperti perangkat jaringan layer 3. Salah satu contohnya adalah kemampuan untuk melakukan routing statik. Jika biasanya untuk melakukan routing statik perlu perangkat router, maka apabila kita memiliki Switch Layer 3, kita tidak perlu menambahkan perangkat router untuk melakukan routing statik.

Pada kesempatan kali ini Gua akan mempraktikan konfigurasi static routing dengan menggunakan perangkat Multilayer Switch atau biasa juga disebut Switch Layer 3. Dan seperti biasanya, Gua akan menggunakan software simulasi Cisco Packet Tracer karena Gua belum mampu untuk membeli perangkat aslinya :'D. Oke lanjut, berikut adalah topologi yang akan Gua gunakan :

 
Pertama-tama mari kita konfigurasi ip address pada PC dan Laptop :
Selanjutnya konfigurasi hostname untuk Switch 1 seperti pada topologi di atas.
Konfigurasi Switch 1 :


Switch>enable
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname MS1
MS1(config)#


Konfigurasi Switch 2  :

Switch>enable
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname MS2
MS2(config)#


Kemudian konfigurasi ip address pada interface vlan1. IP address ini akan menjadi gateway bagi client.

Konfigurasi MS1 :


MS1(config)#interface vlan1
MS1(config-if)#ip address 192.168.1.254 255.255.255.0
MS1(config-if)#no shutdown


MS1(config-if)#
%LINK-5-CHANGED: Interface Vlan1, changed state to up


%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up

MS1(config-if)#exit

Konfigurasi MS2 :

MS2(config)#interface vlan1
MS2(config-if)#ip address 192.168.2.254 255.255.255.0
MS2(config-if)#no shutdown


MS2(config-if)#
%LINK-5-CHANGED: Interface Vlan1, changed state to up


%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up

MS2(config-if)#exit

Setelah itu dilanjutkan dengan konfigurasi ip address pada interface yang menghubungkan antar switch yakni interface gigabit0/1 (g0/1). Namun sebelum kita mengkonfigurasikan ip address, kita perlu menonaktifkan mode switchport yang ada pada inerface tersebut.
Konfigurasi MS1 :


MS1(config)#interface g0/1
MS1(config-if)#no switchport
MS1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to down


%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up

MS1(config-if)#ip address 100.100.100.1 255.255.255.252
MS1(config-if)#exit


Konfigurasi MS2:

MS2(config)#interface g0/1
MS2(config-if)#no switchport
MS2(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to down


%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up

MS2(config-if)#ip address 100.100.100.2 255.255.255.252
MS2(config-if)#exit


Secara default, seluruh port pada Switch Layer 3 mengaktifkan mode switchport yang digunakan untuk menghubungkan host-host dalam jaringan yang sama. Kekurangan dari mode ini adalah, kita tidak bisa mengkonfigurasikan ip address pada interface tersebut, oleh karena itu mode switchport perlu dinonaktifkan terlebih dahulu.

Langkah berikutnya adalah mengaktifkan ip routing agar switch bisa meneruskan paket yang menuju ke jaringan lain.
 

Konfigurasi MS1 :
MS1(config)#ip routing

Konfigurasi MS2 :
MS2(config)#ip routing

Langkah terakhir adalah melakukan konfigurasi routing statik. Meskipun tadi sudah mengaktifkan ip routing, namun konfigurasi static routing tetap perlu dilakukan. Konfigurasinya tidak berbeda dengan static routing pada router.
Konfigurasi MS1 :


MS1(config)#ip route 192.168.2.0 255.255.255.0 100.100.100.2

Konfigurasi MS2 :

MS2(config)#ip route 192.168.1.0 255.255.255.0 100.100.100.1

Lakukan pengujian dengan ping dari PC ke Laptop atau sebaliknya. Tidak perlu panik jika ping pertama atau kedua kali gagal. Lakukan ping kembali sampai sukses. Apabila sudah lebih dali 5 kali tetapi masih gagal maka silahkan cek kembali konfigurasi dan konektivitas kabel nya.
 
Jangan lupa untuk menyimpan konfigurasi yang sudah dilakukan agar tidak hilang ketika switch mengalami down.
Switch 1 :


MS1(config)#do copy run start
Destination filename [startup-config]? 
Building configuration...
[OK]
MS1(config)#


Switch 2 :

MS2(config)#do copy run start
Destination filename [startup-config]? 
Building configuration...
[OK]
MS2(config)#
 

Posting Komentar

0 Komentar